Failed to inject a ConfigMgr driver into the mounted WIM file

Hi Guys,

Had an issue today I want to share with you.

While adding additional drivers to an existing SCCM Boot Image I encountered the following error:

 

Error: Actions to perform:

 

· Add ConfigMgr binaries

 

· Enable Windows PE command line support

 

· Add drivers

 

 

Success: Drivers that will be included:

 

· Intel(R) 82567LM Gigabit Network Connection

 

· Intel(R) 82567LM-2 Gigabit Network Connection

 

· Intel(R) PRO/1000 PT Dual Port Network Connection

 

 

Error: Failed to import the following drivers:

 

· Intel(R) 82567LM Gigabit Network Connection- Failed to inject a ConfigMgr driver into the mounted WIM file

 

 

Error: The wizard detected the following problems when updating the boot image.

 

· Failed to inject a ConfigMgr driver into the mounted WIM file

 

Failed to inject a ConfigMgr driver into the mounted WIM file

 

Failed to inject a ConfigMgr driver into the mounted WIM file

 

The ConfigMgr Provider reported an error.: ConfigMgr Error Object:

 

instance of SMS_ExtendedStatus

 

{

 

Description = “Failed to insert OSD binaries into the WIM file“;

 

ErrorCode = 2152205056;

 

File = “c:\\qfe\\nts_sms_fre\\sms\\siteserver\\sdk_provider\\smsprov\\sspbootimagepackage.cpp“;

 

Line = 4262;

 

ObjectInfo = “CSspBootImagePackage::PreRefreshPkgSrcHook“;

 

Operation = “ExecMethod“;

 

ParameterInfo = “SMS_BootImagePackage.PackageID=\”KST0004D\””;

 

ProviderName = “WinMgmt“;

 

StatusCode = 2147749889;

I made sure that I did everything right (Driver Packages, source, DP and etc…) and nothing, I still encountered the exact same error when I tried updating the Boot Image Distribution Point.

Eventually I found the source of the problem – apparently someone changed the folder names of the original drivers. Although the drivers were already in the SCCM catalog, the folder containing the installation files was moved to a different location.

I could reconfigure the folder to its actual location but I’ve decided to remove the driver completely and recreate it.

Thus I made sure I have all the up-to date drivers, and their location is correct!

Incoming search terms:

  • failed to inject a configmgr driver into the mounted WIM file
  • Failed to inject OSD binaries into mounted WIM file
  • failed to inject a configmgr driver
  • rror: The wizard detected the following problems when updating the boot image •Failed to insert OSD binaries into the mounted WIM fileThe SMS Provider reported an error : ConfigMgr Error Object:instance of SMS_ExtendedStatus
  • sccm boot image failed to inject osd binaries error 2152205056
  • sccm driver injector failed
  • Description = Failed to inject OSD ErrorCode = 2152205056;
  • sccm failed to insert object
  • sccm unable to inject drivers
  • • Failed to inject a ConfigMgr driver into the mounted WIM file StatusCode = 2147749889

What do you think about this post?